]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Assume getaddrinfo() and IPv6 are supported.
[meshlink] / src / Makefile.am
index 8b72c5b522c7e96fcf7f9d6513fb7aa63dfb47a9..bfbee5141ec0136b7f8cceb2395009627d56342d 100644 (file)
@@ -1,15 +1,12 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = sptps_test sptps_keypair
-
-if LINUX
-sbin_PROGRAMS += sptps_speed
-endif
-
-DEFAULT_INCLUDES =
+AM_CPPFLAGS = -Wall
 
 ed25519_SOURCES = \
        ed25519/add_scalar.c \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c \
+       ed25519/ecdsagen.c \
        ed25519/ed25519.h \
        ed25519/fe.c ed25519/fe.h \
        ed25519/fixedint.h \
@@ -28,58 +25,35 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
-sptps_test_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
-sptps_keypair_SOURCES = \
-       crypto.c crypto.h \
-       sptps_keypair.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES)
-
-sptps_speed_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h \
+       utcp/utcp_priv.h
 
 lib_LTLIBRARIES = libmeshlink.la
 
-libmeshlink_la_LDFLAGS = -export-symbols-regex '^meshlink_'
+pkginclude_HEADERS = meshlink++.h meshlink.h
+
+libmeshlink_la_LDFLAGS = -export-symbols $(srcdir)/meshlink.sym
 
 libmeshlink_la_SOURCES = \
-       meshlink.c meshlink.h \
        buffer.c buffer.h \
-       cipher.h \
        conf.c conf.h \
        connection.c connection.h \
        crypto.c crypto.h \
-       discovery.c discovery.h \
        dropin.c dropin.h \
        ecdh.h \
        ecdsa.h \
        ecdsagen.h \
        edge.c edge.h \
        event.c event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.c fake-getaddrinfo.h \
-       fake-getnameinfo.c fake-getnameinfo.h \
        graph.c graph.h \
        hash.c hash.h \
        have.h \
        list.c list.h \
        logger.c logger.h \
+       meshlink.c meshlink.h meshlink.sym \
+       meshlink_internal.h \
+       meshlink_queue.h \
        meta.c meta.h \
        net.c net.h \
        net_packet.c \
@@ -87,6 +61,7 @@ libmeshlink_la_SOURCES = \
        net_socket.c \
        netutl.c netutl.h \
        node.c node.h \
+       submesh.c submesh.h \
        prf.c prf.h \
        protocol.c protocol.h \
        protocol_auth.c \
@@ -94,34 +69,32 @@ libmeshlink_la_SOURCES = \
        protocol_key.c \
        protocol_misc.c \
        route.c route.h \
+       sockaddr.h \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        system.h \
        utils.c utils.h \
        xalloc.h \
+       xoshiro.c xoshiro.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC
+EXTRA_libmeshlink_la_DEPENDENCIES = $(srcdir)/meshlink.sym
 
-libmeshlink_la_LIBADD = -lpthread -lavahi-core -lavahi-common -lavahi-client
+libmeshlink_la_CFLAGS = $(PTHREAD_CFLAGS) -fPIC -iquote.
+libmeshlink_la_LDFLAGS += $(PTHREAD_LIBS)
 
+if CATTA
 libmeshlink_la_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
-sptps_test_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c
-sptps_keypair_SOURCES += \
-       ed25519/ecdsagen.c
-sptps_speed_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
+       discovery.c discovery.h
 
-sptps_speed_LDADD = -lrt
+libmeshlink_la_CFLAGS += -I${top_srcdir}/catta/include/
 
-LIBS = @LIBS@
+if MINGW
+libmeshlink_la_CFLAGS += -I${top_srcdir}/catta/src/compat/windows/include/
+endif
 
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+libmeshlink_la_LIBADD = ${top_builddir}/catta/src/libcatta.la
+endif