]> git.meshlink.io Git - meshlink/blobdiff - test/Makefile.am
Remove old tests for tinc 1.1 and add a basic test for MeshLink.
[meshlink] / test / Makefile.am
index 5457b2fcd6b919a253ee71ce1e0d620f8614e98c..2b72a0a49b9885f0b905d177c8eb32c1c562cda2 100644 (file)
@@ -1,24 +1,11 @@
 TESTS = \
-       basic.test \
-       commandline.test \
-       executables.test \
-       import-export.test \
-       invite-join.test \
-       ns-ping.test \
-       ping.test \
-       sptps-basic.test \
-       variables.test
+       basic.test
 
 dist_check_SCRIPTS = $(TESTS)
 
-EXTRA_DIST = testlib.sh
+AM_CPPFLAGS = -I../src
 
-check_PROGRAMS = pong
+check_PROGRAMS = basic
 
-pong_SOURCES = pong.c
-
-clean-local:
-       -for pid in *.test.?/pid; do ../src/tinc --pidfile="$$pid" stop; done
-       -killall ../src/sptps_test
-       -killall pong
-       -rm -rf *.test.?
+basic_SOURCES = basic.c
+basic_LDADD = ../src/libmeshlink.la