]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Remove files not used by MeshLink.
[meshlink] / src / Makefile.am
index 6c2ab9a9567cdbb1e342085acd79a0d08e822d75..fab950898e554a590d433f40d2f284adb76c7d3b 100644 (file)
@@ -1,6 +1,6 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test
+sbin_PROGRAMS = sptps_test
 
 if LINUX
 sbin_PROGRAMS += sptps_speed
@@ -8,7 +8,22 @@ endif
 
 DEFAULT_INCLUDES =
 
-tincd_SOURCES = \
+sptps_test_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_test.c \
+       utils.c utils.h
+
+sptps_speed_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_speed.c \
+       utils.c utils.h
+
+lib_LTLIBRARIES = libmeshlink.la
+
+libmeshlink_la_SOURCES = \
+       libmeshlink.c libmeshlink.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \
@@ -16,10 +31,8 @@ tincd_SOURCES = \
        control.c control.h \
        control_common.h \
        crypto.h \
-       device.h \
        digest.h \
        dropin.c dropin.h \
-       dummy_device.c \
        ecdh.h \
        ecdsa.h \
        ecdsagen.h \
@@ -39,7 +52,6 @@ tincd_SOURCES = \
        list.c list.h \
        logger.c logger.h \
        meta.c meta.h \
-       multicast_device.c \
        names.c names.h \
        net.c net.h \
        net_packet.c \
@@ -55,7 +67,6 @@ tincd_SOURCES = \
        protocol_key.c \
        protocol_misc.c \
        protocol_subnet.c \
-       raw_socket_device.c \
        route.c route.h \
        rsa.h \
        rsagen.h \
@@ -69,82 +80,11 @@ tincd_SOURCES = \
        utils.c utils.h \
        xalloc.h
 
-tinc_SOURCES = \
-       dropin.c dropin.h \
-       getopt.c getopt.h \
-       getopt1.c \
-       info.c info.h \
-       invitation.c invitation.h \
-       list.c list.h \
-       names.c names.h \
-       netutl.c netutl.h \
-       script.c script.h \
-       sptps.c sptps.h \
-       subnet_parse.c subnet.h \
-       tincctl.c tincctl.h \
-       top.c top.h \
-       utils.c utils.h
+libmeshlink_la_CFLAGS = -fPIC
 
-sptps_test_SOURCES = \
-       logger.c logger.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h
+libmeshlink_la_LIBADD = -lpthread
 
-sptps_speed_SOURCES = \
-       logger.c logger.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h
-
-lib_LTLIBRARIES = libmeshlink.la
-
-libmeshlink_la_SOURCES = \
-       libmeshlink.c libmeshlink.h
-
-## Conditionally compile device drivers
-       
-if LINUX
-tincd_SOURCES += linux/device.c
-endif
-
-if BSD
-tincd_SOURCES += bsd/device.c
-if TUNEMU
-tincd_SOURCES += bsd/tunemu.c bsd/tunemu.h
-endif
-endif
-
-if SOLARIS
-tincd_SOURCES += solaris/device.c
-endif
-
-if MINGW
-tincd_SOURCES += mingw/device.c mingw/common.h
-endif
-
-if CYGWIN
-tincd_SOURCES += cygwin/device.c
-endif
-
-if UML
-tincd_SOURCES += uml_device.c
-endif
-
-if VDE
-tincd_SOURCES += vde_device.c
-endif
-
-if OPENSSL
-tincd_SOURCES += \
-       openssl/cipher.c \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
-       openssl/prf.c \
-       openssl/rsa.c
-tinc_SOURCES += \
+libmeshlink_la_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
        openssl/digest.c openssl/digest.h \
@@ -169,43 +109,9 @@ sptps_speed_SOURCES += \
        openssl/ecdsa.c \
        openssl/ecdsagen.c \
        openssl/prf.c
-endif
-
-if GCRYPT
-tincd_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/prf.c \
-       gcrypt/rsa.c
-tinc_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/ecdsagen.c \
-       gcrypt/prf.c \
-       gcrypt/rsa.c \
-       gcrypt/rsagen.c
-sptps_test_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c gcrypt/digest.h \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/prf.c
-endif
 
-tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
 sptps_speed_LDADD = -lrt
 
 LIBS = @LIBS@
 
-if TUNEMU
-LIBS += -lpcap
-endif
-
 AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"