]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Remove files not used by MeshLink.
[meshlink] / src / Makefile.am
index 57e0b694d0f7b8b25b978ab66720fe487cb00b45..fab950898e554a590d433f40d2f284adb76c7d3b 100644 (file)
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tinc sptps_test
+sbin_PROGRAMS = sptps_test
 
-EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
+if LINUX
+sbin_PROGRAMS += sptps_speed
+endif
+
+DEFAULT_INCLUDES =
+
+sptps_test_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_test.c \
+       utils.c utils.h
+
+sptps_speed_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_speed.c \
+       utils.c utils.h
+
+lib_LTLIBRARIES = libmeshlink.la
 
-tincd_SOURCES = \
-       buffer.c \
-       conf.c \
-       connection.c \
-       control.c \
-       dropin.c \
-       dummy_device.c \
-       edge.c \
-       event.c \
-       fake-getaddrinfo.c \
-       fake-getnameinfo.c \
-       getopt.c \
+libmeshlink_la_SOURCES = \
+       libmeshlink.c libmeshlink.h \
+       buffer.c buffer.h \
+       cipher.h \
+       conf.c conf.h \
+       connection.c connection.h \
+       control.c control.h \
+       control_common.h \
+       crypto.h \
+       digest.h \
+       dropin.c dropin.h \
+       ecdh.h \
+       ecdsa.h \
+       ecdsagen.h \
+       edge.c edge.h \
+       ethernet.h \
+       event.c event.h \
+       fake-gai-errnos.h \
+       fake-getaddrinfo.c fake-getaddrinfo.h \
+       fake-getnameinfo.c fake-getnameinfo.h \
+       getopt.c getopt.h \
        getopt1.c \
-       graph.c \
-       hash.c \
-       list.c \
-       logger.c \
-       meta.c \
-       multicast_device.c \
-       names.c \
-       net.c \
+       graph.c graph.h \
+       hash.c hash.h \
+       have.h \
+       ipv4.h \
+       ipv6.h \
+       list.c list.h \
+       logger.c logger.h \
+       meta.c meta.h \
+       names.c names.h \
+       net.c net.h \
        net_packet.c \
        net_setup.c \
        net_socket.c \
-       netutl.c \
-       node.c \
-       process.c \
-       protocol.c \
+       netutl.c netutl.h \
+       node.c node.h \
+       prf.h \
+       process.c process.h \
+       protocol.c protocol.h \
        protocol_auth.c \
        protocol_edge.c \
        protocol_key.c \
        protocol_misc.c \
        protocol_subnet.c \
-       raw_socket_device.c \
-       route.c \
-       splay_tree.c \
-       sptps.c \
-       subnet.c \
+       route.c route.h \
+       rsa.h \
+       rsagen.h \
+       script.c script.h \
+       splay_tree.c splay_tree.h \
+       sptps.c sptps.h \
+       subnet.c subnet.h \
        subnet_parse.c \
+       system.h \
        tincd.c \
-       utils.c
-
-tinc_SOURCES = \
-       dropin.c \
-       getopt.c \
-       getopt1.c \
-       info.c \
-       invitation.c \
-       list.c \
-       names.c \
-       netutl.c \
-       sptps.c \
-       subnet_parse.c \
-       tincctl.c \
-       top.c \
-       utils.c
-
-sptps_test_SOURCES = \
-       logger.c \
-       sptps.c \
-       sptps_test.c \
-       utils.c
-
-## Conditionally compile device drivers
-       
-if LINUX
-tincd_SOURCES += linux/device.c
-endif
-
-if BSD
-tincd_SOURCES += bsd/device.c
-if TUNEMU
-tincd_SOURCES += bsd/tunemu.c
-endif
-endif
-
-if SOLARIS
-tincd_SOURCES += solaris/device.c
-endif
-
-if MINGW
-tincd_SOURCES += mingw/device.c
-endif
-
-if CYGWIN
-tincd_SOURCES += cygwin/device.c
-endif
+       utils.c utils.h \
+       xalloc.h
 
-if UML
-tincd_SOURCES += uml_device.c
-endif
+libmeshlink_la_CFLAGS = -fPIC
 
-if VDE
-tincd_SOURCES += vde_device.c
-endif
+libmeshlink_la_LIBADD = -lpthread
 
-if OPENSSL
-tincd_SOURCES += \
-       openssl/cipher.c \
-       openssl/crypto.c \
-       openssl/digest.c \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
-       openssl/prf.c \
-       openssl/rsa.c
-tinc_SOURCES += \
+libmeshlink_la_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
-       openssl/digest.c \
+       openssl/digest.c openssl/digest.h \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/ecdsagen.c \
@@ -122,98 +97,21 @@ tinc_SOURCES += \
 sptps_test_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
-       openssl/digest.c \
+       openssl/digest.c openssl/digest.h \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/prf.c
-endif
-
-if GCRYPT
-tincd_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/prf.c \
-       gcrypt/rsa.c
-tinc_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/ecdsagen.c \
-       gcrypt/prf.c \
-       gcrypt/rsa.c \
-       gcrypt/rsagen.c
-sptps_test_SOURCES += \
-       gcrypt/cipher.c \
-       gcrypt/crypto.c \
-       gcrypt/digest.c \
-       gcrypt/ecdh.c \
-       gcrypt/ecdsa.c \
-       gcrypt/prf.c
-endif
-
-tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
-
-noinst_HEADERS = \
-       buffer.h \
-       cipher.h \
-       conf.h \
-       connection.h \
-       control.h \
-       control_common.h \
-       crypto.h \
-       device.h \
-       digest.h \
-       dropin.h \
-       ecdh.h \
-       ecdsa.h \
-       ecdsagen.h \
-       edge.h \
-       ethernet.h \
-       event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.h \
-       fake-getnameinfo.h \
-       getopt.h \
-       graph.h \
-       hash.h \
-       have.h \
-       info.h \
-       ipv4.h \
-       ipv6.h \
-       list.h \
-       logger.h \
-       meta.h \
-       names.h \
-       net.h \
-       netutl.h \
-       node.h \
-       prf.h \
-       process.h \
-       protocol.h \
-       route.h \
-       rsa.h \
-       rsagen.h
-       splay_tree.h \
-       sptps.h \
-       subnet.h \
-       system.h \
-       tincctl.h \
-       top.h \
-       utils.h \
-       xalloc.h
+sptps_speed_SOURCES += \
+       openssl/cipher.c \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/ecdh.c \
+       openssl/ecdsa.c \
+       openssl/ecdsagen.c \
+       openssl/prf.c
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+sptps_speed_LDADD = -lrt
 
-if TUNEMU
-LIBS += -lpcap
-endif
+LIBS = @LIBS@
 
 AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
-
-dist-hook:
-       rm -f `find . -type l`