]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Merge branch 'master' into 1.1
[meshlink] / src / Makefile.am
index ed110e9f15c3359bc622186b577f632de0c13762..db90897ff60d1d01c71d20cf8f15d176880a1a20 100644 (file)
@@ -11,6 +11,10 @@ tincd_SOURCES = cipher.c conf.c connection.c control.c crypto.c digest.c edge.c
 
 tincctl_SOURCES = tincctl.c rsagen.c
 
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
+
 nodist_tincd_SOURCES = device.c
 
 DEFAULT_INCLUDES =
@@ -18,10 +22,14 @@ DEFAULT_INCLUDES =
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
 noinst_HEADERS = cipher.h conf.h connection.h control.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h      \
-       protocol.h route.h rsa.h rsagen.h subnet.h
+       protocol.h route.h rsa.h rsagen.h subnet.h bsd/tunemu.h
 
 LIBS = @LIBS@ @LIBGCRYPT_LIBS@ @LIBINTL@
 
+if TUNEMU
+LIBS += -lpcap
+endif
+
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a