]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Merge branch 'master' into 1.1
[meshlink] / src / Makefile.am
index 501fdf66953875873d88289e60dc36ea26308961..db90897ff60d1d01c71d20cf8f15d176880a1a20 100644 (file)
@@ -1,13 +1,15 @@
 ## Produce this file with automake to get Makefile.in
 # $Id: Makefile.am,v 1.4.4.33 2003/08/02 15:13:08 guus Exp $
 
-sbin_PROGRAMS = tincd
+sbin_PROGRAMS = tincd tincctl
 
 EXTRA_DIST = linux/device.c bsd/device.c solaris/device.c cygwin/device.c mingw/device.c mingw/common.h raw_socket/device.c uml_socket/device.c
 
-tincd_SOURCES = conf.c connection.c edge.c event.c graph.c logger.c meta.c net.c net_packet.c net_setup.c      \
+tincd_SOURCES = cipher.c conf.c connection.c control.c crypto.c digest.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c       \
-       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
+       protocol_key.c protocol_subnet.c route.c rsa.c subnet.c tincd.c
+
+tincctl_SOURCES = tincctl.c rsagen.c
 
 if TUNEMU
 tincd_SOURCES += bsd/tunemu.c
@@ -19,10 +21,10 @@ DEFAULT_INCLUDES =
 
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
-noinst_HEADERS = conf.h connection.h device.h edge.h event.h graph.h logger.h meta.h net.h netutl.h node.h process.h   \
-       protocol.h route.h subnet.h bsd/tunemu.h
+noinst_HEADERS = cipher.h conf.h connection.h control.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h      \
+       protocol.h route.h rsa.h rsagen.h subnet.h bsd/tunemu.h
 
-LIBS = @LIBS@ @LIBINTL@
+LIBS = @LIBS@ @LIBGCRYPT_LIBS@ @LIBINTL@
 
 if TUNEMU
 LIBS += -lpcap
@@ -31,9 +33,12 @@ endif
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
+tincctl_LDADD = \
+       $(top_builddir)/lib/libvpn.a
+
 localedir = $(datadir)/locale
 
-AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\"
+AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
 
 dist-hook:
        rm -f `find . -type l`