]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
json export of node and edge structure
[meshlink] / src / Makefile.am
index 8f02c06d063a950f0db532cc5125ac95637bc2b1..cae2ab95458666bd89d738bae7eab34890788914 100644 (file)
@@ -56,13 +56,16 @@ sptps_speed_SOURCES = \
 
 lib_LTLIBRARIES = libmeshlink.la
 
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
+
 libmeshlink_la_SOURCES = \
-       libmeshlink.c libmeshlink.h \
+       meshlink.c meshlink.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \
        connection.c connection.h \
        crypto.c crypto.h \
+       discovery.c discovery.h \
        dropin.c dropin.h \
        ecdh.h \
        ecdsa.h \
@@ -94,15 +97,15 @@ libmeshlink_la_SOURCES = \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        system.h \
-       tincd.c \
        utils.c utils.h \
        xalloc.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC
+libmeshlink_la_CFLAGS = -fPIC -I../avahi/
 
-libmeshlink_la_LIBADD = -lpthread
+libmeshlink_la_LIBADD = -lpthread -luuid ../avahi/avahi-core/.libs/libavahi-core.a ../avahi/avahi-common/.libs/libavahi-common.a
 
 libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \