]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Import UTCP as a git submodule.
[meshlink] / src / Makefile.am
index 9a92c422ef4d9fc7842d69fc64ce8bf928ecadf5..c1d887e9759d2e0687bcda210aafd92c01a66bcd 100644 (file)
@@ -28,6 +28,9 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h
+
 sptps_test_SOURCES = \
        crypto.c crypto.h \
        logger.c logger.h \
@@ -99,7 +102,8 @@ libmeshlink_la_SOURCES = \
        utils.c utils.h \
        xalloc.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
 libmeshlink_la_CFLAGS = -fPIC