]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Merge branch 'master' into 1.1
[meshlink] / src / Makefile.am
index ed110e9f15c3359bc622186b577f632de0c13762..bb78d4dd9d55692cf0ec13521012ebf467c14d6a 100644 (file)
@@ -1,5 +1,4 @@
 ## Produce this file with automake to get Makefile.in
-# $Id: Makefile.am,v 1.4.4.33 2003/08/02 15:13:08 guus Exp $
 
 sbin_PROGRAMS = tincd tincctl
 
@@ -11,6 +10,10 @@ tincd_SOURCES = cipher.c conf.c connection.c control.c crypto.c digest.c edge.c
 
 tincctl_SOURCES = tincctl.c rsagen.c
 
+if TUNEMU
+tincd_SOURCES += bsd/tunemu.c
+endif
+
 nodist_tincd_SOURCES = device.c
 
 DEFAULT_INCLUDES =
@@ -18,9 +21,13 @@ DEFAULT_INCLUDES =
 INCLUDES = @INCLUDES@ -I$(top_builddir) -I$(top_srcdir)/lib
 
 noinst_HEADERS = cipher.h conf.h connection.h control.h crypto.h device.h digest.h edge.h graph.h logger.h meta.h net.h netutl.h node.h process.h      \
-       protocol.h route.h rsa.h rsagen.h subnet.h
+       protocol.h route.h rsa.h rsagen.h subnet.h bsd/tunemu.h
+
+LIBS = @LIBS@ @LIBGCRYPT_LIBS@
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@ @LIBINTL@
+if TUNEMU
+LIBS += -lpcap
+endif
 
 tincd_LDADD = \
        $(top_builddir)/lib/libvpn.a
@@ -28,9 +35,7 @@ tincd_LDADD = \
 tincctl_LDADD = \
        $(top_builddir)/lib/libvpn.a
 
-localedir = $(datadir)/locale
-
-AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALEDIR=\"$(localedir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
+AM_CFLAGS = @CFLAGS@ -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
 
 dist-hook:
        rm -f `find . -type l`