]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Merge branch 'master' of git://tinc-vpn.org/tinc into 1.1
[meshlink] / src / Makefile.am
index 186c042c898169a68bb96bdba400003118bb1984..ba8b34793cd68cf6827d02bb2afa54b66b103b52 100644 (file)
@@ -1,14 +1,23 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = tincd tincctl
+sbin_PROGRAMS = tincd tincctl sptps_test
 
-EXTRA_DIST = linux bsd solaris cygwin mingw raw_socket uml_socket openssl gcrypt
+EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
 
 tincd_SOURCES = \
        utils.c getopt.c getopt1.c list.c splay_tree.c dropin.c fake-getaddrinfo.c fake-getnameinfo.c \
        buffer.c conf.c connection.c control.c edge.c graph.c logger.c meta.c net.c net_packet.c net_setup.c \
        net_socket.c netutl.c node.c process.c protocol.c protocol_auth.c protocol_edge.c protocol_misc.c \
-       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c
+       protocol_key.c protocol_subnet.c route.c subnet.c tincd.c \
+       dummy_device.c raw_socket_device.c
+       
+if UML
+tincd_SOURCES += uml_device.c
+endif
+
+if VDE
+tincd_SOURCES += vde_device.c
+endif
 
 nodist_tincd_SOURCES = \
        device.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c rsa.c
@@ -20,6 +29,10 @@ tincctl_SOURCES = \
 nodist_tincctl_SOURCES = \
        ecdsagen.c rsagen.c
 
+sptps_test_SOURCES = \
+       logger.c cipher.c crypto.c ecdh.c ecdsa.c digest.c prf.c \
+       sptps.c sptps_test.c
+
 if TUNEMU
 tincd_SOURCES += bsd/tunemu.c
 endif