]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Merge branch 'channels'
[meshlink] / src / Makefile.am
index 0c681acbc533cc7c836972a1367533c700000ab9..a2a9305ac54e32f219be1439581d728b5fb66f13 100644 (file)
@@ -28,6 +28,9 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h
+
 sptps_test_SOURCES = \
        crypto.c crypto.h \
        logger.c logger.h \
@@ -56,7 +59,7 @@ sptps_speed_SOURCES = \
 
 lib_LTLIBRARIES = libmeshlink.la
 
-libmeshlink_la_LDFLAGS = -export-symbols-regex '^meshlink_'
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
 
 libmeshlink_la_SOURCES = \
        meshlink.c meshlink.h \
@@ -99,8 +102,10 @@ libmeshlink_la_SOURCES = \
        system.h \
        utils.c utils.h \
        xalloc.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
 libmeshlink_la_CFLAGS = -fPIC -I../avahi/