]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Only export symbols that start with meshlink_.
[meshlink] / src / Makefile.am
index 6f7cd7956d512d8cb73fe2f6ece355745d913ff7..9a92c422ef4d9fc7842d69fc64ce8bf928ecadf5 100644 (file)
@@ -56,6 +56,8 @@ sptps_speed_SOURCES = \
 
 lib_LTLIBRARIES = libmeshlink.la
 
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^meshlink_'
+
 libmeshlink_la_SOURCES = \
        meshlink.c meshlink.h \
        buffer.c buffer.h \