]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Get rid of OpenSSL entirely.
[meshlink] / src / Makefile.am
index 083b2728641049205bee646a06c5159c0eb0e6a1..8f02c06d063a950f0db532cc5125ac95637bc2b1 100644 (file)
@@ -23,24 +23,36 @@ ed25519_SOURCES = \
        ed25519/sign.c \
        ed25519/verify.c
 
+chacha_poly1305_SOURCES = \
+       chacha-poly1305/chacha.c chacha-poly1305/chacha.h \
+       chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
+       chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
+
 sptps_test_SOURCES = \
+       crypto.c crypto.h \
        logger.c logger.h \
+       prf.c prf.h \
        sptps.c sptps.h \
        sptps_test.c \
        utils.c utils.h \
-       $(ed25519_SOURCES)
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 sptps_keypair_SOURCES = \
+       crypto.c crypto.h \
        sptps_keypair.c \
        utils.c utils.h \
        $(ed25519_SOURCES)
 
 sptps_speed_SOURCES = \
+       crypto.c crypto.h \
        logger.c logger.h \
+       prf.c prf.h \
        sptps.c sptps.h \
        sptps_speed.c \
        utils.c utils.h \
-       $(ed25519_SOURCES)
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 lib_LTLIBRARIES = libmeshlink.la
 
@@ -50,8 +62,7 @@ libmeshlink_la_SOURCES = \
        cipher.h \
        conf.c conf.h \
        connection.c connection.h \
-       crypto.h \
-       digest.h \
+       crypto.c crypto.h \
        dropin.c dropin.h \
        ecdh.h \
        ecdsa.h \
@@ -73,7 +84,7 @@ libmeshlink_la_SOURCES = \
        net_socket.c \
        netutl.c netutl.h \
        node.c node.h \
-       prf.h \
+       prf.c prf.h \
        protocol.c protocol.h \
        protocol_auth.c \
        protocol_edge.c \
@@ -86,38 +97,26 @@ libmeshlink_la_SOURCES = \
        tincd.c \
        utils.c utils.h \
        xalloc.h \
-       $(ed25519_SOURCES)
+       $(ed25519_SOURCES) \
+       $(chacha_poly1305_SOURCES)
 
 libmeshlink_la_CFLAGS = -fPIC
 
 libmeshlink_la_LIBADD = -lpthread
 
 libmeshlink_la_SOURCES += \
-       openssl/cipher.c \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
-       openssl/ecdsagen.c \
-       openssl/prf.c
-sptps_test_SOURCES += \
-       openssl/cipher.c \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
-       openssl/prf.c
+       ed25519/ecdsagen.c
+sptps_test_SOURCES += \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c
 sptps_keypair_SOURCES += \
-       openssl/crypto.c \
        ed25519/ecdsagen.c
 sptps_speed_SOURCES += \
-       openssl/cipher.c \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
-       ed25519/ecdsagen.c \
-       openssl/prf.c
+       ed25519/ecdsagen.c
 
 sptps_speed_LDADD = -lrt