]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Move UTCP into the MeshLink repository.
[meshlink] / src / Makefile.am
index d855d3a5a0ffc13e683336bedd081aadc751cd5d..7d2e94e74921106802dfb29c2165d95318b1544a 100644 (file)
@@ -26,10 +26,11 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
 utcp_SOURCES = \
-       utcp/utcp.c utcp/utcp.h \
-       utcp/utcp_priv.h
+       utcp.c utcp.h \
+       utcp_priv.h
 
 lib_LTLIBRARIES = libmeshlink.la
+noinst_PROGRAMS = utcp-test
 
 pkginclude_HEADERS = meshlink++.h meshlink.h
 
@@ -82,6 +83,10 @@ libmeshlink_la_SOURCES = \
        $(chacha_poly1305_SOURCES) \
        $(utcp_SOURCES)
 
+utcp_test_SOURCES = \
+       utcp-test.c \
+       $(utcp_SOURCES)
+
 EXTRA_libmeshlink_la_DEPENDENCIES = $(srcdir)/meshlink.sym
 
 libmeshlink_la_CFLAGS = $(PTHREAD_CFLAGS) -fPIC -iquote.