]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Use AX_PTHREAD to set the proper pthread flags.
[meshlink] / src / Makefile.am
index bead49e64acaaa2fa06b237864f4a0c95f05144c..7b8dd148e447138fb627bd9573ab364458037376 100644 (file)
@@ -1,12 +1,6 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = sptps_test sptps_keypair
-
-if LINUX
-sbin_PROGRAMS += sptps_speed
-endif
-
-DEFAULT_INCLUDES =
+AM_CPPFLAGS = -Wall
 
 ed25519_SOURCES = \
        ed25519/add_scalar.c \
@@ -28,40 +22,18 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
-sptps_test_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
-sptps_keypair_SOURCES = \
-       crypto.c crypto.h \
-       sptps_keypair.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES)
-
-sptps_speed_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h \
+       utcp/utcp_priv.h
 
 lib_LTLIBRARIES = libmeshlink.la
 
-libmeshlink_la_LDFLAGS = -export-symbols-regex '^meshlink_'
+pkginclude_HEADERS = meshlink++.h meshlink.h
+
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
 
 libmeshlink_la_SOURCES = \
-       meshlink.c meshlink.h \
        buffer.c buffer.h \
-       cipher.h \
        conf.c conf.h \
        connection.c connection.h \
        crypto.c crypto.h \
@@ -80,6 +52,9 @@ libmeshlink_la_SOURCES = \
        have.h \
        list.c list.h \
        logger.c logger.h \
+       meshlink.c meshlink.h \
+       meshlink_internal.h \
+       meshlink_queue.h \
        meta.c meta.h \
        net.c net.h \
        net_packet.c \
@@ -94,34 +69,27 @@ libmeshlink_la_SOURCES = \
        protocol_key.c \
        protocol_misc.c \
        route.c route.h \
+       sockaddr.h \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        system.h \
        utils.c utils.h \
        xalloc.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC -I../avahi/
+libmeshlink_la_CFLAGS = $(PTHREAD_CFLAGS) -fPIC -I${top_srcdir}/catta/include/ -iquote.
+
+if MINGW
+libmeshlink_la_CFLAGS += -I${top_srcdir}/catta/src/compat/windows/include/
+endif
 
-libmeshlink_la_LIBADD = -lpthread -luuid ../avahi/avahi-core/.libs/libavahi-core.a ../avahi/avahi-common/.libs/libavahi-common.a ../avahi/avahi-client/.libs/libavahi-client.a
+libmeshlink_la_LDFLAGS = $(PTHREAD_LIBS)
+libmeshlink_la_LIBADD = ${top_builddir}/catta/src/libcatta.la
 
 libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c
-sptps_test_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c
-sptps_keypair_SOURCES += \
-       ed25519/ecdsagen.c
-sptps_speed_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
-
-sptps_speed_LDADD = -lrt
-
-LIBS = @LIBS@
-
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"