]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Add our own autoconf check for libgcrypt.
[meshlink] / src / Makefile.am
index 27d2330b063edd374fe893b20a9466c8f67d3d55..64c845d60e278a305e3aa8bdb84d3bcf4472b8e5 100644 (file)
@@ -2,7 +2,9 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test
 
-EXTRA_DIST = linux bsd solaris cygwin mingw openssl gcrypt
+if LINUX
+sbin_PROGRAMS += sptps_speed
+endif
 
 DEFAULT_INCLUDES =
 
@@ -57,6 +59,7 @@ tincd_SOURCES = \
        route.c route.h \
        rsa.h \
        rsagen.h \
+       script.c script.h \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        subnet.c subnet.h \
@@ -75,6 +78,7 @@ tinc_SOURCES = \
        list.c list.h \
        names.c names.h \
        netutl.c netutl.h \
+       script.c script.h \
        sptps.c sptps.h \
        subnet_parse.c subnet.h \
        tincctl.c tincctl.h \
@@ -87,6 +91,12 @@ sptps_test_SOURCES = \
        sptps_test.c \
        utils.c utils.h
 
+sptps_speed_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_speed.c \
+       utils.c utils.h
+
 ## Conditionally compile device drivers
        
 if LINUX
@@ -96,7 +106,7 @@ endif
 if BSD
 tincd_SOURCES += bsd/device.c
 if TUNEMU
-tincd_SOURCES += bsd/tunemu.c
+tincd_SOURCES += bsd/tunemu.c bsd/tunemu.h
 endif
 endif
 
@@ -105,7 +115,7 @@ tincd_SOURCES += solaris/device.c
 endif
 
 if MINGW
-tincd_SOURCES += mingw/device.c
+tincd_SOURCES += mingw/device.c mingw/common.h
 endif
 
 if CYGWIN
@@ -124,7 +134,7 @@ if OPENSSL
 tincd_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
-       openssl/digest.c \
+       openssl/digest.c openssl/digest.h \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/prf.c \
@@ -132,7 +142,7 @@ tincd_SOURCES += \
 tinc_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
-       openssl/digest.c \
+       openssl/digest.c openssl/digest.h \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/ecdsagen.c \
@@ -142,17 +152,25 @@ tinc_SOURCES += \
 sptps_test_SOURCES += \
        openssl/cipher.c \
        openssl/crypto.c \
-       openssl/digest.c \
+       openssl/digest.c openssl/digest.h \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/prf.c
+sptps_speed_SOURCES += \
+       openssl/cipher.c \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/ecdh.c \
+       openssl/ecdsa.c \
+       openssl/ecdsagen.c \
+       openssl/prf.c
 endif
 
 if GCRYPT
 tincd_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
-       gcrypt/digest.c \
+       gcrypt/digest.c gcrypt/digest.h \
        gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
        gcrypt/prf.c \
@@ -160,7 +178,7 @@ tincd_SOURCES += \
 tinc_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
-       gcrypt/digest.c \
+       gcrypt/digest.c gcrypt/digest.h \
        gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
        gcrypt/ecdsagen.c \
@@ -170,21 +188,19 @@ tinc_SOURCES += \
 sptps_test_SOURCES += \
        gcrypt/cipher.c \
        gcrypt/crypto.c \
-       gcrypt/digest.c \
+       gcrypt/digest.c gcrypt/digest.h \
        gcrypt/ecdh.c \
        gcrypt/ecdsa.c \
        gcrypt/prf.c
 endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
+sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+LIBS = @LIBS@
 
 if TUNEMU
 LIBS += -lpcap
 endif
 
 AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"
-
-dist-hook:
-       rm -f `find . -type l`