]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Add our own autoconf check for libgcrypt.
[meshlink] / src / Makefile.am
index 2738008be028bd26b175c112203477d579a52ba9..64c845d60e278a305e3aa8bdb84d3bcf4472b8e5 100644 (file)
@@ -2,6 +2,10 @@
 
 sbin_PROGRAMS = tincd tinc sptps_test
 
+if LINUX
+sbin_PROGRAMS += sptps_speed
+endif
+
 DEFAULT_INCLUDES =
 
 tincd_SOURCES = \
@@ -55,6 +59,7 @@ tincd_SOURCES = \
        route.c route.h \
        rsa.h \
        rsagen.h \
+       script.c script.h \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        subnet.c subnet.h \
@@ -73,6 +78,7 @@ tinc_SOURCES = \
        list.c list.h \
        names.c names.h \
        netutl.c netutl.h \
+       script.c script.h \
        sptps.c sptps.h \
        subnet_parse.c subnet.h \
        tincctl.c tincctl.h \
@@ -85,6 +91,12 @@ sptps_test_SOURCES = \
        sptps_test.c \
        utils.c utils.h
 
+sptps_speed_SOURCES = \
+       logger.c logger.h \
+       sptps.c sptps.h \
+       sptps_speed.c \
+       utils.c utils.h
+
 ## Conditionally compile device drivers
        
 if LINUX
@@ -144,6 +156,14 @@ sptps_test_SOURCES += \
        openssl/ecdh.c \
        openssl/ecdsa.c \
        openssl/prf.c
+sptps_speed_SOURCES += \
+       openssl/cipher.c \
+       openssl/crypto.c \
+       openssl/digest.c openssl/digest.h \
+       openssl/ecdh.c \
+       openssl/ecdsa.c \
+       openssl/ecdsagen.c \
+       openssl/prf.c
 endif
 
 if GCRYPT
@@ -175,8 +195,9 @@ sptps_test_SOURCES += \
 endif
 
 tinc_LDADD = $(READLINE_LIBS) $(CURSES_LIBS)
+sptps_speed_LDADD = -lrt
 
-LIBS = @LIBS@ @LIBGCRYPT_LIBS@
+LIBS = @LIBS@
 
 if TUNEMU
 LIBS += -lpcap