]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Remove unused/duplicate autoconf/automake definitions.
[meshlink] / src / Makefile.am
index 6f50a083fc4cf2f8fdac3d45a8f75d872745ca95..6340a1a2a22b8da0054a195305042f951b70ed03 100644 (file)
@@ -1,11 +1,5 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = sptps_test sptps_keypair
-
-if LINUX
-sbin_PROGRAMS += sptps_speed
-endif
-
 DEFAULT_INCLUDES =
 
 ed25519_SOURCES = \
@@ -31,34 +25,10 @@ chacha_poly1305_SOURCES = \
 utcp_SOURCES = \
        utcp/utcp.c utcp/utcp.h
 
-sptps_test_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
-sptps_keypair_SOURCES = \
-       crypto.c crypto.h \
-       sptps_keypair.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES)
-
-sptps_speed_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
 lib_LTLIBRARIES = libmeshlink.la
 
+pkginclude_HEADERS = meshlink++.h meshlink.h
+
 libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
 
 libmeshlink_la_SOURCES = \
@@ -107,26 +77,15 @@ libmeshlink_la_SOURCES = \
        $(chacha_poly1305_SOURCES) \
        $(utcp_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC -I../catta/
+libmeshlink_la_CFLAGS = -fPIC -I../catta/include/
+
+if MINGW
+libmeshlink_la_CFLAGS += -I../catta/src/compat/windows/include/
+endif
 
-libmeshlink_la_LIBADD = -lpthread -luuid ../catta/avahi-core/.libs/libavahi-core.a ../catta/avahi-common/.libs/libavahi-common.a
+libmeshlink_la_LIBADD = -lpthread ../catta/src/libcatta.la
 
 libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c
-sptps_test_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c
-sptps_keypair_SOURCES += \
-       ed25519/ecdsagen.c
-sptps_speed_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
-
-sptps_speed_LDADD = -lrt
-
-LIBS = @LIBS@
-
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"