]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Remove unused/duplicate autoconf/automake definitions.
[meshlink] / src / Makefile.am
index 11dc219e6f1ba3794ed1a108ad937d53865ae246..6340a1a2a22b8da0054a195305042f951b70ed03 100644 (file)
@@ -1,11 +1,5 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = sptps_test sptps_keypair
-
-if LINUX
-sbin_PROGRAMS += sptps_speed
-endif
-
 DEFAULT_INCLUDES =
 
 ed25519_SOURCES = \
@@ -31,32 +25,6 @@ chacha_poly1305_SOURCES = \
 utcp_SOURCES = \
        utcp/utcp.c utcp/utcp.h
 
-sptps_test_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
-sptps_keypair_SOURCES = \
-       crypto.c crypto.h \
-       sptps_keypair.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES)
-
-sptps_speed_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
-
 lib_LTLIBRARIES = libmeshlink.la
 
 pkginclude_HEADERS = meshlink++.h meshlink.h
@@ -121,18 +89,3 @@ libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c
-sptps_test_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c
-sptps_keypair_SOURCES += \
-       ed25519/ecdsagen.c
-sptps_speed_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
-
-sptps_speed_LDADD = -lrt
-
-LIBS = @LIBS@
-
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"