]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Remove unused/duplicate autoconf/automake definitions.
[meshlink] / src / Makefile.am
index 021d6b8ef537f2b016ceed061c44169c038022eb..6340a1a2a22b8da0054a195305042f951b70ed03 100644 (file)
@@ -1,11 +1,5 @@
 ## Produce this file with automake to get Makefile.in
 
-sbin_PROGRAMS = sptps_test sptps_keypair
-
-if LINUX
-sbin_PROGRAMS += sptps_speed
-endif
-
 DEFAULT_INCLUDES =
 
 ed25519_SOURCES = \
@@ -28,33 +22,14 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
-sptps_test_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_test.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h
 
-sptps_keypair_SOURCES = \
-       crypto.c crypto.h \
-       sptps_keypair.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES)
+lib_LTLIBRARIES = libmeshlink.la
 
-sptps_speed_SOURCES = \
-       crypto.c crypto.h \
-       logger.c logger.h \
-       prf.c prf.h \
-       sptps.c sptps.h \
-       sptps_speed.c \
-       utils.c utils.h \
-       $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+pkginclude_HEADERS = meshlink++.h meshlink.h
 
-lib_LTLIBRARIES = libmeshlink.la
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
 
 libmeshlink_la_SOURCES = \
        meshlink.c meshlink.h \
@@ -63,6 +38,7 @@ libmeshlink_la_SOURCES = \
        conf.c conf.h \
        connection.c connection.h \
        crypto.c crypto.h \
+       discovery.c discovery.h \
        dropin.c dropin.h \
        ecdh.h \
        ecdsa.h \
@@ -94,32 +70,22 @@ libmeshlink_la_SOURCES = \
        splay_tree.c splay_tree.h \
        sptps.c sptps.h \
        system.h \
-       tincd.c \
        utils.c utils.h \
        xalloc.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC
+libmeshlink_la_CFLAGS = -fPIC -I../catta/include/
 
-libmeshlink_la_LIBADD = -lpthread
+if MINGW
+libmeshlink_la_CFLAGS += -I../catta/src/compat/windows/include/
+endif
+
+libmeshlink_la_LIBADD = -lpthread ../catta/src/libcatta.la
 
 libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
        ed25519/ecdsagen.c
-sptps_test_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c
-sptps_keypair_SOURCES += \
-       ed25519/ecdsagen.c
-sptps_speed_SOURCES += \
-       ed25519/ecdh.c \
-       ed25519/ecdsa.c \
-       ed25519/ecdsagen.c
-
-sptps_speed_LDADD = -lrt
-
-LIBS = @LIBS@
-
-AM_CFLAGS = -DCONFDIR=\"$(sysconfdir)\" -DLOCALSTATEDIR=\"$(localstatedir)\" -DSBINDIR=\"$(sbindir)\"