]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
trying to fix linking issues
[meshlink] / src / Makefile.am
index b5cac5a53be46b20b543f1db7e1a471cfc600b25..31dfae5ee19e4dee3fa40439a28799e00d8eaf56 100644 (file)
@@ -9,7 +9,6 @@ endif
 DEFAULT_INCLUDES =
 
 tincd_SOURCES = \
-       libmeshlink.c libmeshlink.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \
@@ -70,6 +69,8 @@ tincd_SOURCES = \
        utils.c utils.h \
        xalloc.h
 
+tincd_CFLAGS = -fPIC
+
 tinc_SOURCES = \
        dropin.c dropin.h \
        getopt.c getopt.h \
@@ -86,6 +87,8 @@ tinc_SOURCES = \
        top.c top.h \
        utils.c utils.h
 
+tinc_CFLAGS = -fPIC
+
 sptps_test_SOURCES = \
        logger.c logger.h \
        sptps.c sptps.h \
@@ -98,6 +101,15 @@ sptps_speed_SOURCES = \
        sptps_speed.c \
        utils.c utils.h
 
+lib_LTLIBRARIES = libmeshlink.la
+
+libmeshlink_la_SOURCES = \
+       libmeshlink.c libmeshlink.h
+
+libmeshlink_la_CFLAGS = -fPIC
+
+libmeshlink_la_LIBADD = \
+       protocol.o protocol_auth.o
 
 ## Conditionally compile device drivers