]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
windows compatibility
[meshlink] / src / Makefile.am
index 0c681acbc533cc7c836972a1367533c700000ab9..11dc219e6f1ba3794ed1a108ad937d53865ae246 100644 (file)
@@ -28,6 +28,9 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/chacha-poly1305.c chacha-poly1305/chacha-poly1305.h \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
+utcp_SOURCES = \
+       utcp/utcp.c utcp/utcp.h
+
 sptps_test_SOURCES = \
        crypto.c crypto.h \
        logger.c logger.h \
@@ -56,7 +59,9 @@ sptps_speed_SOURCES = \
 
 lib_LTLIBRARIES = libmeshlink.la
 
-libmeshlink_la_LDFLAGS = -export-symbols-regex '^meshlink_'
+pkginclude_HEADERS = meshlink++.h meshlink.h
+
+libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
 
 libmeshlink_la_SOURCES = \
        meshlink.c meshlink.h \
@@ -99,12 +104,18 @@ libmeshlink_la_SOURCES = \
        system.h \
        utils.c utils.h \
        xalloc.h \
+       devtools.c devtools.h \
        $(ed25519_SOURCES) \
-       $(chacha_poly1305_SOURCES)
+       $(chacha_poly1305_SOURCES) \
+       $(utcp_SOURCES)
 
-libmeshlink_la_CFLAGS = -fPIC -I../avahi/
+libmeshlink_la_CFLAGS = -fPIC -I../catta/include/
+
+if MINGW
+libmeshlink_la_CFLAGS += -I../catta/src/compat/windows/include/
+endif
 
-libmeshlink_la_LIBADD = -lpthread -luuid ../avahi/avahi-core/.libs/libavahi-core.a ../avahi/avahi-common/.libs/libavahi-common.a
+libmeshlink_la_LIBADD = -lpthread ../catta/src/libcatta.la
 
 libmeshlink_la_SOURCES += \
        ed25519/ecdh.c \