]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Start moving the implementation of the public part of the API to meshlink.c.
[meshlink] / src / Makefile.am
index bf2122d23568cc24df6d9de3bb4f85ce6138f466..021d6b8ef537f2b016ceed061c44169c038022eb 100644 (file)
@@ -29,7 +29,9 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
 sptps_test_SOURCES = \
+       crypto.c crypto.h \
        logger.c logger.h \
+       prf.c prf.h \
        sptps.c sptps.h \
        sptps_test.c \
        utils.c utils.h \
@@ -37,12 +39,15 @@ sptps_test_SOURCES = \
        $(chacha_poly1305_SOURCES)
 
 sptps_keypair_SOURCES = \
+       crypto.c crypto.h \
        sptps_keypair.c \
        utils.c utils.h \
        $(ed25519_SOURCES)
 
 sptps_speed_SOURCES = \
+       crypto.c crypto.h \
        logger.c logger.h \
+       prf.c prf.h \
        sptps.c sptps.h \
        sptps_speed.c \
        utils.c utils.h \
@@ -52,13 +57,12 @@ sptps_speed_SOURCES = \
 lib_LTLIBRARIES = libmeshlink.la
 
 libmeshlink_la_SOURCES = \
-       libmeshlink.c libmeshlink.h \
+       meshlink.c meshlink.h \
        buffer.c buffer.h \
        cipher.h \
        conf.c conf.h \
        connection.c connection.h \
-       crypto.h \
-       digest.h \
+       crypto.c crypto.h \
        dropin.c dropin.h \
        ecdh.h \
        ecdsa.h \
@@ -80,7 +84,7 @@ libmeshlink_la_SOURCES = \
        net_socket.c \
        netutl.c netutl.h \
        node.c node.h \
-       prf.h \
+       prf.c prf.h \
        protocol.c protocol.h \
        protocol_auth.c \
        protocol_edge.c \
@@ -101,28 +105,18 @@ libmeshlink_la_CFLAGS = -fPIC
 libmeshlink_la_LIBADD = -lpthread
 
 libmeshlink_la_SOURCES += \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
-       openssl/ecdh.c \
-       openssl/ecdsa.c \
-       openssl/ecdsagen.c \
-       openssl/prf.c
-sptps_test_SOURCES += \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
-       openssl/prf.c
+       ed25519/ecdsagen.c
+sptps_test_SOURCES += \
+       ed25519/ecdh.c \
+       ed25519/ecdsa.c
 sptps_keypair_SOURCES += \
-       openssl/crypto.c \
        ed25519/ecdsagen.c
 sptps_speed_SOURCES += \
-       openssl/crypto.c \
-       openssl/digest.c openssl/digest.h \
        ed25519/ecdh.c \
        ed25519/ecdsa.c \
-       ed25519/ecdsagen.c \
-       openssl/prf.c
+       ed25519/ecdsagen.c
 
 sptps_speed_LDADD = -lrt