]> git.meshlink.io Git - meshlink/blobdiff - src/Makefile.am
Ensure utcp-test is compiled with the same flags as libmeshlink.
[meshlink] / src / Makefile.am
index f793e91256da71e7ef038f111b409d29c22da772..01e6ff2870b5bf4e907827ba1d011e931668f698 100644 (file)
@@ -26,16 +26,18 @@ chacha_poly1305_SOURCES = \
        chacha-poly1305/poly1305.c chacha-poly1305/poly1305.h
 
 utcp_SOURCES = \
-       utcp/utcp.c utcp/utcp.h \
-       utcp/utcp_priv.h
+       utcp.c utcp.h \
+       utcp_priv.h
 
 lib_LTLIBRARIES = libmeshlink.la
+noinst_PROGRAMS = utcp-test
 
 pkginclude_HEADERS = meshlink++.h meshlink.h
 
-libmeshlink_la_LDFLAGS = -export-symbols-regex '^(meshlink_|devtool_)'
+libmeshlink_la_LDFLAGS = -export-symbols $(srcdir)/meshlink.sym
 
 libmeshlink_la_SOURCES = \
+       adns.c adns.h \
        buffer.c buffer.h \
        conf.c conf.h \
        connection.c connection.h \
@@ -46,15 +48,12 @@ libmeshlink_la_SOURCES = \
        ecdsagen.h \
        edge.c edge.h \
        event.c event.h \
-       fake-gai-errnos.h \
-       fake-getaddrinfo.c fake-getaddrinfo.h \
-       fake-getnameinfo.c fake-getnameinfo.h \
        graph.c graph.h \
        hash.c hash.h \
        have.h \
        list.c list.h \
        logger.c logger.h \
-       meshlink.c meshlink.h \
+       meshlink.c meshlink.h meshlink.sym \
        meshlink_internal.h \
        meshlink_queue.h \
        meta.c meta.h \
@@ -65,6 +64,7 @@ libmeshlink_la_SOURCES = \
        netutl.c netutl.h \
        node.c node.h \
        submesh.c submesh.h \
+       packmsg.h \
        prf.c prf.h \
        protocol.c protocol.h \
        protocol_auth.c \
@@ -78,14 +78,24 @@ libmeshlink_la_SOURCES = \
        system.h \
        utils.c utils.h \
        xalloc.h \
+       xoshiro.c xoshiro.h \
        devtools.c devtools.h \
        $(ed25519_SOURCES) \
        $(chacha_poly1305_SOURCES) \
        $(utcp_SOURCES)
 
+utcp_test_SOURCES = \
+       utcp-test.c \
+       $(utcp_SOURCES)
+
+EXTRA_libmeshlink_la_DEPENDENCIES = $(srcdir)/meshlink.sym
+
 libmeshlink_la_CFLAGS = $(PTHREAD_CFLAGS) -fPIC -iquote.
 libmeshlink_la_LDFLAGS += $(PTHREAD_LIBS)
 
+utcp_test_CFLAGS = $(PTHREAD_CFLAGS) -iquote.
+utcp_test_LDFLAGS = $(PTHREAD_LIBS)
+
 if CATTA
 libmeshlink_la_SOURCES += \
        discovery.c discovery.h