]> git.meshlink.io Git - meshlink/blobdiff - examples/Makefile.am
Add a groupchat example program that uses the submesh feature.
[meshlink] / examples / Makefile.am
index 4d363657bfe1f2d754baedd7d61478d31c1310cb..fbd71382525d7ab1f2b119b03243a59b9be154a8 100644 (file)
@@ -1,4 +1,4 @@
-noinst_PROGRAMS = meshlinkapp chat chatpp manynodes channels
+noinst_PROGRAMS = meshlinkapp chat chatpp manynodes channels monitor groupchat
 
 AM_CPPFLAGS = $(PTHREAD_CFLAGS) -I${top_srcdir}/src -iquote. -Wall
 AM_LDFLAGS = $(PTHREAD_LIBS)
@@ -17,3 +17,11 @@ manynodes_LDADD = ${top_builddir}/src/libmeshlink.la
 
 channels_SOURCES = channels.c
 channels_LDADD = ${top_builddir}/src/libmeshlink.la
+
+if CURSES
+monitor_SOURCES = monitor.c
+monitor_LDADD = ${top_builddir}/src/libmeshlink.la $(NCURSES_LIBS) -lm
+endif
+
+groupchat_SOURCES = groupchat.c
+groupchat_LDADD = ${top_builddir}/src/libmeshlink.la