]> git.meshlink.io Git - meshlink/blobdiff - examples/Makefile.am
Use AX_PTHREAD to set the proper pthread flags.
[meshlink] / examples / Makefile.am
index 462f9d966edb9a8e2c6deef1dc0339286a888804..5c7f27186b18ca0f4e6288a6f41f500dd5d9aacd 100644 (file)
@@ -1,6 +1,7 @@
 noinst_PROGRAMS = meshlinkapp chat chatpp manynodes channels
 
-AM_CPPFLAGS = -I${top_srcdir}/src -iquote. -Wall
+AM_CPPFLAGS = $(PTHREAD_CFLAGS) -I${top_srcdir}/src -iquote. -Wall
+AM_LDFLAGS = $(PTHREAD_LIBS)
 
 meshlinkapp_SOURCES = meshlinkapp.c
 meshlinkapp_LDADD = ${top_builddir}/src/libmeshlink.la ${top_builddir}/catta/src/libcatta.la