]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Avoid allocating packet buffers unnecessarily.
[meshlink] / doc / Makefile.am
index ba681caffce1dd1558a9e909310764481a78402a..9fa98b6b52b02bbfcb6b3468eab7425c6c5d8fc8 100644 (file)
@@ -1,12 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-info_TEXINFOS = tinc.texi
+info_TEXINFOS = meshlink.texi
 
-man_MANS = tincd.8 tinc.conf.5
+man_MANS =
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tinc.conf.5.in sample-config.tar.gz
+EXTRA_DIST = include.texi.in
 
-CLEANFILES = *.html
+CLEANFILES = *.html include.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -16,11 +16,13 @@ transform = s/ginstall/install/; @program_transform_name@
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
 
-sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) --exclude .svn chozf sample-config.tar.gz sample-config
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
 
-texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
-
-%.html: $(man_MANS)
-       w3mman2html $< > $@
+include.texi: include.texi.in
+       $(substitute) $? > $@
+       
+meshlink.texi: include.texi