]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Avoid allocating packet buffers unnecessarily.
[meshlink] / doc / Makefile.am
index 9f3f7ebdcb5212a56d4986ac76cd792aa6de9cb5..9fa98b6b52b02bbfcb6b3468eab7425c6c5d8fc8 100644 (file)
@@ -1,20 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-SUBDIRS = es
+info_TEXINFOS = meshlink.texi
 
-info_TEXINFOS = tinc.texi
+man_MANS =
 
-dyn_MANS =
-man_aux = $(dyn_MANS:.8=.x)
+EXTRA_DIST = include.texi.in
 
-man_MANS = tincd.8 tinc.conf.5 genauth.8 $(dyn_MANS)
-
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
-
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tinc.conf.sample
+CLEANFILES = *.html include.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -23,3 +15,14 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+include.texi: include.texi.in
+       $(substitute) $? > $@
+       
+meshlink.texi: include.texi