]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Avoid allocating packet buffers unnecessarily.
[meshlink] / doc / Makefile.am
index 8f0305e4c2901d9e2f1dc90b98eed61bacb94c06..9fa98b6b52b02bbfcb6b3468eab7425c6c5d8fc8 100644 (file)
@@ -1,12 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-info_TEXINFOS = tinc.texi
+info_TEXINFOS = meshlink.texi
 
-man_MANS = tincd.8 tincctl.8 tinc.conf.5 tinc-gui.8
+man_MANS =
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tincctl.8.in tinc.conf.5.in tinc-gui.8.in sample-config.tar.gz
+EXTRA_DIST = include.texi.in
 
-CLEANFILES = *.html tinc.info tincd.8 tincctl.8 tinc.conf.5 tinc-gui.8 tincinclude.texi
+CLEANFILES = *.html include.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -16,43 +16,13 @@ transform = s/ginstall/install/; @program_transform_name@
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
 
-sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
-
-texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
-
-tincd.8.html: tincd.8
-       w3mman2html $< > $@
-
-tincctl.8.html: tincctl.8
-       w3mman2html $< > $@
-
-tinc-gui.8.html: tinc-gui.8
-       w3mman2html $< > $@
-
-tinc.conf.5.html: tinc.conf.5
-       w3mman2html $< > $@
-
 substitute = sed \
        -e s,'@PACKAGE\@',"$(PACKAGE)",g \
        -e s,'@VERSION\@',"$(VERSION)",g \
        -e s,'@sysconfdir\@',"$(sysconfdir)",g \
        -e s,'@localstatedir\@',"$(localstatedir)",g
 
-tincd.8: tincd.8.in
-       $(substitute) $< > $@
-
-tincctl.8: tincctl.8.in
-       $(substitute) $< > $@
-
-tinc-gui.8: tinc-gui.8.in
-       $(substitute) $< > $@
-
-tinc.conf.5: tinc.conf.5.in
-       $(substitute) $< > $@
-
-tincinclude.texi: tincinclude.texi.in
-       $(substitute) $< > $@
+include.texi: include.texi.in
+       $(substitute) $? > $@
        
-tinc.texi: tincinclude.texi
+meshlink.texi: include.texi