]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Avoid allocating packet buffers unnecessarily.
[meshlink] / doc / Makefile.am
index 3caf69d6ecbb813245111a1f8fb4d8e104ac9417..9fa98b6b52b02bbfcb6b3468eab7425c6c5d8fc8 100644 (file)
@@ -1,18 +1,12 @@
 ## Process this file with automake to get Makefile.in
 
-info_TEXINFOS = tinc.texi
+info_TEXINFOS = meshlink.texi
 
-dyn_MANS = tincd.8
-man_aux = $(dyn_MANS:.8=.x)
+man_MANS =
 
-man_MANS = tincd.conf.5 genauth.8 $(dyn_MANS)
+EXTRA_DIST = include.texi.in
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
-
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tincd.conf.sample
+CLEANFILES = *.html include.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -21,3 +15,14 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+include.texi: include.texi.in
+       $(substitute) $? > $@
+       
+meshlink.texi: include.texi