]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Remove files not used by MeshLink.
[meshlink] / doc / Makefile.am
index ed2ec2e2c3731632c6bf285ac75f286279f54ef7..56d81e32fcd2e2494a94bd184133224f18bd0d02 100644 (file)
@@ -2,17 +2,11 @@
 
 info_TEXINFOS = tinc.texi
 
-dyn_MANS = tincd.8
-man_aux = $(dyn_MANS:.8=.x)
+man_MANS =
 
-man_MANS = tincd.conf.5 $(dyn_MANS)
+EXTRA_DIST = tincinclude.texi.in
 
-PERL = @PERL@
-HELP2MAN = help2man
-MAINTAINERCLEANFILES = $(dyn_MANS)
-
-EXTRA_DIST = $(man_MANS) $(HELP2MAN) $(man_aux) \
-  Makefile.maint GNUmakefile Makefile.summ tincd.conf.sample
+CLEANFILES = *.html tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -21,3 +15,14 @@ transform = s/ginstall/install/; @program_transform_name@
 
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
+
+substitute = sed \
+       -e s,'@PACKAGE\@',"$(PACKAGE)",g \
+       -e s,'@VERSION\@',"$(VERSION)",g \
+       -e s,'@sysconfdir\@',"$(sysconfdir)",g \
+       -e s,'@localstatedir\@',"$(localstatedir)",g
+
+tincinclude.texi: tincinclude.texi.in
+       $(substitute) $? > $@
+       
+tinc.texi: tincinclude.texi