]> git.meshlink.io Git - meshlink/blobdiff - doc/Makefile.am
Remove files not used by MeshLink.
[meshlink] / doc / Makefile.am
index 66de6d93c2e1b223f87494d4c4c35a1f39520dde..56d81e32fcd2e2494a94bd184133224f18bd0d02 100644 (file)
@@ -2,11 +2,11 @@
 
 info_TEXINFOS = tinc.texi
 
-man_MANS = tincd.8 tincctl.8 tinc.conf.5
+man_MANS =
 
-EXTRA_DIST = tincinclude.texi.in tincd.8.in tincctl.8.in tinc.conf.5.in sample-config.tar.gz
+EXTRA_DIST = tincinclude.texi.in
 
-CLEANFILES = *.html tinc.info tincd.8 tincctl.8 tinc.conf.5 tincinclude.texi
+CLEANFILES = *.html tincinclude.texi
 
 # Use `ginstall' in the definition of man_MANS to avoid
 # confusion with the `install' target.  The install rule transforms `ginstall'
@@ -16,37 +16,13 @@ transform = s/ginstall/install/; @program_transform_name@
 # For additional rules usually of interest only to the maintainer,
 # see GNUmakefile and Makefile.maint.
 
-sample-config.tar.gz: sample-config
-       GZIP=$(GZIP_ENV) $(AMTAR) chozf sample-config.tar.gz --exclude .svn sample-config
-
-texi2html: tinc.texi
-       texi2html -split=chapter tinc.texi
-
-tincd.8.html: tincd.8
-       w3mman2html $< > $@
-
-tincctl.8.html: tincctl.8
-       w3mman2html $< > $@
-
-tinc.conf.5.html: tinc.conf.5
-       w3mman2html $< > $@
-
 substitute = sed \
        -e s,'@PACKAGE\@',"$(PACKAGE)",g \
        -e s,'@VERSION\@',"$(VERSION)",g \
        -e s,'@sysconfdir\@',"$(sysconfdir)",g \
        -e s,'@localstatedir\@',"$(localstatedir)",g
 
-tincd.8: tincd.8.in
-       $(substitute) tincd.8.in > tincd.8
-
-tincctl.8: tincctl.8.in
-       $(substitute) tincctl.8.in > tincctl.8
-
-tinc.conf.5: tinc.conf.5.in
-       $(substitute) tinc.conf.5.in > tinc.conf.5
-
 tincinclude.texi: tincinclude.texi.in
-       $(substitute) tincinclude.texi.in > tincinclude.texi
+       $(substitute) $? > $@
        
 tinc.texi: tincinclude.texi