]> git.meshlink.io Git - catta/blobdiff - tests/Makefile.am
Fix compilation error caused by ACX_THREAD
[catta] / tests / Makefile.am
index 8cd35c3b5db552db7019e5ce4f1186eb05cc965e..5b144658c8b892e5965c7af767926d8e8c50ccc4 100644 (file)
@@ -35,16 +35,20 @@ noinst_PROGRAMS = \
        conformance-test \
        catta-reflector \
        dns-test \
-       dns-spin-test \
        timeeventq-test \
        hashmap-test \
        querier-test \
        update-test
 
 TESTS = \
-       dns-spin-test \
        dns-test \
        hashmap-test
+
+# disable the dns-spin-test on Windows (needs setitimer)
+if !WINDOWS
+noinst_PROGRAMS += dns-spin-test
+TESTS += dns-spin-test
+endif
 endif