]> git.meshlink.io Git - catta/blobdiff - examples/Makefile.am
rename everything avahi to catta
[catta] / examples / Makefile.am
index d8191030f6c196bf287eb5894e7ec6d107e20fd1..c7faa918a55f4b44da18dd226a3712b583a82d81 100644 (file)
@@ -1,32 +1,32 @@
-# $Id$
+# This file is part of catta.
 #
-# This file is part of avahi.
-# 
-# avahi is free software; you can redistribute it and/or modify it
+# catta is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
 # License, or (at your option) any later version.
 #
-# avahi is distributed in the hope that it will be useful, but WITHOUT
+# catta is distributed in the hope that it will be useful, but WITHOUT
 # ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
 # or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
 # License for more details.
 #
 # You should have received a copy of the GNU Lesser General Public
-# License along with avahi; if not, write to the Free Software
+# License along with catta; if not, write to the Free Software
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA.
 
-AM_CFLAGS=-I$(top_srcdir)
+AM_CFLAGS=-I$(top_srcdir)/include
 
+if ENABLE_TESTS
 noinst_PROGRAMS = \
-       publish-service \
-       browse-services
+       core-publish-service \
+       core-browse-services
+endif
 
-publish_service_SOURCES = publish-service.c
-publish_service_CFLAGS = $(AM_CFLAGS)
-publish_service_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_publish_service_SOURCES = core-publish-service.c
+core_publish_service_CFLAGS = $(AM_CFLAGS)
+core_publish_service_LDADD = $(AM_LDADD) ../src/libcatta.la
 
-browse_services_SOURCES = browse-services.c
-browse_services_CFLAGS = $(AM_CFLAGS)
-browse_services_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_browse_services_SOURCES = core-browse-services.c
+core_browse_services_CFLAGS = $(AM_CFLAGS)
+core_browse_services_LDADD = $(AM_LDADD) ../src/libcatta.la