]> git.meshlink.io Git - catta/blobdiff - examples/Makefile.am
combine avahi-core and avahi-common components into one library
[catta] / examples / Makefile.am
index e7be1bf2a83e50ce82a1dd90b65b46fdfbe5778d..aff7d3c1906585906de79abc8a70f63c5f9805f7 100644 (file)
@@ -1,7 +1,5 @@
-# $Id$
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
 
 AM_CFLAGS=-I$(top_srcdir)
 
-# GLIB 2.0
-AM_CFLAGS+=$(GLIB20_CFLAGS)
-AM_LDADD=$(GLIB20_LIBS)
-
+if ENABLE_TESTS
 noinst_PROGRAMS = \
-       publish-service \
-       browse-services
+       core-publish-service \
+       core-browse-services
+endif
 
-publish_service_SOURCES = publish-service.c
-publish_service_CFLAGS = $(AM_CFLAGS)
-publish_service_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_publish_service_SOURCES = core-publish-service.c
+core_publish_service_CFLAGS = $(AM_CFLAGS)
+core_publish_service_LDADD = $(AM_LDADD) ../avahi/libavahi.la
 
-browse_services_SOURCES = browse-services.c
-browse_services_CFLAGS = $(AM_CFLAGS)
-browse_services_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_browse_services_SOURCES = core-browse-services.c
+core_browse_services_CFLAGS = $(AM_CFLAGS)
+core_browse_services_LDADD = $(AM_LDADD) ../avahi/libavahi.la