]> git.meshlink.io Git - catta/blobdiff - examples/Makefile.am
move public headers into their own directory
[catta] / examples / Makefile.am
index e6e66f58deecc682326600f073468539a5caaace..15718fe496b971d194118abe758ce4befc318916 100644 (file)
@@ -1,7 +1,5 @@
-# $Id$
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
@@ -17,7 +15,7 @@
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA.
 
-AM_CFLAGS=-I$(top_srcdir)
+AM_CFLAGS=-I$(top_srcdir)/include
 
 if ENABLE_TESTS
 noinst_PROGRAMS = \
@@ -27,39 +25,8 @@ endif
 
 core_publish_service_SOURCES = core-publish-service.c
 core_publish_service_CFLAGS = $(AM_CFLAGS)
-core_publish_service_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_publish_service_LDADD = $(AM_LDADD) ../src/libavahi.la
 
 core_browse_services_SOURCES = core-browse-services.c
 core_browse_services_CFLAGS = $(AM_CFLAGS)
-core_browse_services_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
-
-if HAVE_DBUS
-if ENABLE_TESTS
-
-noinst_PROGRAMS += \
-       client-publish-service \
-       client-browse-services
-endif
-
-client_publish_service_SOURCES = client-publish-service.c
-client_publish_service_CFLAGS = $(AM_CFLAGS)
-client_publish_service_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
-
-client_browse_services_SOURCES = client-browse-services.c
-client_browse_services_CFLAGS = $(AM_CFLAGS)
-client_browse_services_LDADD = $(AM_LDADD) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la
-
-if HAVE_GLIB
-
-if ENABLE_TESTS
-noinst_PROGRAMS += \
-       glib-integration
-endif
-
-glib_integration_SOURCES = glib-integration.c
-glib_integration_CFLAGS = $(AM_CFLAGS) $(GLIB20_CFLAGS)
-glib_integration_LDADD = $(AM_LDADD) $(GLIB20_LIBS) ../avahi-client/libavahi-client.la ../avahi-common/libavahi-common.la ../avahi-glib/libavahi-glib.la
-
-endif
-
-endif
+core_browse_services_LDADD = $(AM_LDADD) ../src/libavahi.la