]> git.meshlink.io Git - catta/blobdiff - examples/Makefile.am
move public headers into their own directory
[catta] / examples / Makefile.am
index d8191030f6c196bf287eb5894e7ec6d107e20fd1..15718fe496b971d194118abe758ce4befc318916 100644 (file)
@@ -1,7 +1,5 @@
-# $Id$
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA.
 
-AM_CFLAGS=-I$(top_srcdir)
+AM_CFLAGS=-I$(top_srcdir)/include
 
+if ENABLE_TESTS
 noinst_PROGRAMS = \
-       publish-service \
-       browse-services
+       core-publish-service \
+       core-browse-services
+endif
 
-publish_service_SOURCES = publish-service.c
-publish_service_CFLAGS = $(AM_CFLAGS)
-publish_service_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_publish_service_SOURCES = core-publish-service.c
+core_publish_service_CFLAGS = $(AM_CFLAGS)
+core_publish_service_LDADD = $(AM_LDADD) ../src/libavahi.la
 
-browse_services_SOURCES = browse-services.c
-browse_services_CFLAGS = $(AM_CFLAGS)
-browse_services_LDADD = $(AM_LDADD) ../avahi-core/libavahi-core.la ../avahi-common/libavahi-common.la
+core_browse_services_SOURCES = core-browse-services.c
+core_browse_services_CFLAGS = $(AM_CFLAGS)
+core_browse_services_LDADD = $(AM_LDADD) ../src/libavahi.la