]> git.meshlink.io Git - catta/blobdiff - avahi-ui-sharp/Makefile.am
add a makefile rule for zssh.exe, and add a .pc file for avahi-ui-sharp
[catta] / avahi-ui-sharp / Makefile.am
index b7f020e851e9e4a8d30f63a486d228cfe1127136..ab58dd24d512fd2d9c4b8625f26fc8440f782fac 100644 (file)
@@ -37,9 +37,12 @@ $(ASSEMBLY): $(AVAHISOURCES)
 $(ASSEMBLY).config: $(ASSEMBLY).config.in
        $(srcdir)/gencfg.sh $(top_builddir)/avahi-common/libavahi-common.la < $< > $@
 
+zssh.exe: zssh.cs
+       mcs -out:$@ zssh.cs -r:./avahi-ui-sharp.dll -pkg:gtk-sharp-2.0 -r:Mono.Posix
+
 if HAVE_MONO
 if HAVE_DBUS
-all: $(ASSEMBLY) $(ASSEMBLY).config
+all: $(ASSEMBLY) $(ASSEMBLY).config zssh.exe
 
 if HAVE_MONODOC
 update-docs: $(ASSEMBLY)