]> git.meshlink.io Git - catta/blobdiff - avahi-sharp/Makefile.am
move avahi-sharp.pc to the root directory
[catta] / avahi-sharp / Makefile.am
index e91271522594bd860d09cbf8c7e7233a66806e4f..bd3e7e1ec6bdb48c8a037570a6d941d0af8f1bd9 100644 (file)
@@ -3,7 +3,7 @@
 ASSEMBLY = avahi-sharp.dll
 
 CLEANFILES = $(ASSEMBLY) $(ASSEMBLY).mdb
-EXTRA_DIST = $(AVAHISOURCES) avahi.snk avahi-sharp.pc.in
+EXTRA_DIST = $(AVAHISOURCES) avahi.snk
 
 AVAHISOURCES =                                 \
        $(srcdir)/AssemblyInfo.cs       \
@@ -24,14 +24,6 @@ $(ASSEMBLY): $(AVAHISOURCES)
 if HAVE_MONO
 all: $(ASSEMBLY)
 
-pkgcfgdir = $(libdir)/pkgconfig
-pkgcfg_DATA = avahi-sharp.pc
-
-avahi-sharp.pc: avahi-sharp.pc.in
-       sed -e 's,@prefix\@,$(prefix),g' \
-           -e 's,@PACKAGE_VERSION\@,$(PACKAGE_VERSION),g' \
-           -e 's,@libdir\@,$(libdir),g' $< > $@
-
 install-data-hook:
        $(GACUTIL) /i $(ASSEMBLY) /package avahi-sharp /gacdir $(libdir) /root $(DESTDIR)$(libdir)
 endif