]> git.meshlink.io Git - catta/blobdiff - avahi-python/avahi/Makefile.am
build-sys: actually, we need to place the service type database in lib64, not uncondi...
[catta] / avahi-python / avahi / Makefile.am
index b16868257413e7518f51fb9ce4b94a8b90e94474..3eb67d0df438a7f8b0f8e0d470a4fe7a68102625 100644 (file)
@@ -1,5 +1,3 @@
-# $Id$
-
 # This file is part of avahi.
 #
 # avahi is free software; you can redistribute it and/or modify it
 
 EXTRA_DIST = __init__.py ServiceTypeDatabase.py.in
 
+pkglibdatadir=$(libdir)/avahi
+
 if HAVE_PYTHON
 
 avahidir = $(pythondir)/avahi
 
-
 if HAVE_GDBM
 nodist_avahi_SCRIPTS = ServiceTypeDatabase.py
 
@@ -33,7 +32,7 @@ ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
                -e 's,@FIRST_KEY\@,key = self.db.firstkey(),g' \
                -e 's,@CHECK_KEY\@,while key is not None:,g' \
                -e 's,@NEXT_KEY\@,key = self.db.nextkey(key),g' \
-               -e 's,@pkglibdir\@,$(pkglibdir),g' $< > $@ && \
+               -e 's,@pkglibdatadir\@,$(pkglibdatadir),g' $< > $@ && \
        chmod +x $@
 endif
 
@@ -46,7 +45,7 @@ ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
                -e 's,@FIRST_KEY\@,keys = self.db.keys(),g' \
                -e 's,@CHECK_KEY\@,for key in keys:,g' \
                -e 's,@NEXT_KEY\@,,g' \
-               -e 's,@pkglibdir\@,$(pkglibdir),g' $< > $@ && \
+               -e 's,@pkglibdatadir\@,$(pkglibdatadir),g' $< > $@ && \
        chmod +x $@
 endif