]> git.meshlink.io Git - catta/blobdiff - avahi-python/avahi/Makefile.am
build-sys: compatibility with newer automake
[catta] / avahi-python / avahi / Makefile.am
index c974171980beb57b123ee019253383fe10283b4d..081398631bdb4641144a878260b0d6a8fe74db51 100644 (file)
@@ -1,5 +1,3 @@
-# $Id$
-
 # This file is part of avahi.
 #
 # avahi is free software; you can redistribute it and/or modify it
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA.
 
-EXTRA_DIST = __init__.py SimpleGladeApp.py ServiceTypeDatabase.py.in
+EXTRA_DIST = __init__.py ServiceTypeDatabase.py.in
+
+pkglibdatadir=$(prefix)/lib/avahi
 
 if HAVE_PYTHON
 
 avahidir = $(pythondir)/avahi
 
-
 if HAVE_GDBM
 nodist_avahi_SCRIPTS = ServiceTypeDatabase.py
 
 ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
-       sed -e 's,@PYTHON\@,$(PYTHON),g' \
+       $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \
                -e 's,@DBM\@,gdbm,g' \
                -e 's,@FIRST_KEY\@,key = self.db.firstkey(),g' \
                -e 's,@CHECK_KEY\@,while key is not None:,g' \
                -e 's,@NEXT_KEY\@,key = self.db.nextkey(key),g' \
-               -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
+               -e 's,@pkglibdatadir\@,$(pkglibdatadir),g' $< > $@ && \
        chmod +x $@
 endif
 
@@ -41,23 +40,21 @@ if HAVE_DBM
 nodist_avahi_SCRIPTS = ServiceTypeDatabase.py
 
 ServiceTypeDatabase.py: ServiceTypeDatabase.py.in
-       sed -e 's,@PYTHON\@,$(PYTHON),g' \
+       $(AM_V_GEN)sed -e 's,@PYTHON\@,$(PYTHON),g' \
                -e 's,@DBM\@,dbm,g' \
                -e 's,@FIRST_KEY\@,keys = self.db.keys(),g' \
                -e 's,@CHECK_KEY\@,for key in keys:,g' \
                -e 's,@NEXT_KEY\@,,g' \
-               -e 's,@pkgdatadir\@,$(pkgdatadir),g' $< > $@
+               -e 's,@pkglibdatadir\@,$(pkglibdatadir),g' $< > $@ && \
        chmod +x $@
 endif
 
 avahi_PYTHON = $(avahi_SCRIPTS)
 
-if HAVE_PYGTK
 if HAVE_PYTHON_DBUS
 
-avahi_PYTHON += __init__.py SimpleGladeApp.py 
+avahi_PYTHON += __init__.py
 
-endif
 endif
 endif