]> git.meshlink.io Git - catta/blobdiff - avahi-core/Makefile.am
forgot to pull the publish_no_reverse change to the example.
[catta] / avahi-core / Makefile.am
index 6e1d99205b4a92f892baa8aa305fd99f53096b68..2f095967718e8ffa26655157a39b0dec52525ed6 100644 (file)
@@ -1,7 +1,5 @@
-# $Id$
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
@@ -32,7 +30,7 @@ avahiinclude_HEADERS = \
        lookup.h
 
 lib_LTLIBRARIES = \
-       libavahi-core.la 
+       libavahi-core.la
 
 if ENABLE_TESTS
 noinst_PROGRAMS = \
@@ -51,7 +49,7 @@ TESTS = \
        dns-spin-test \
        dns-test \
        hashmap-test
-endif  
+endif
 
 libavahi_core_la_SOURCES = \
        timeeventq.c timeeventq.h\
@@ -92,15 +90,18 @@ libavahi_core_la_SOURCES += \
        iface-linux.c iface-linux.h \
        netlink.c netlink.h
 else
-if HAVE_PF_ROUTE 
+if HAVE_PF_ROUTE
 libavahi_core_la_SOURCES += \
        iface-pfroute.c iface-pfroute.h
+else
+libavahi_core_la_SOURCES += \
+       iface-none.c
 endif
 endif
 
 libavahi_core_la_CFLAGS = $(AM_CFLAGS)
 libavahi_core_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
-libavahi_core_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_CORE_VERSION_INFO)
+libavahi_core_la_LDFLAGS = $(AM_LDFLAGS)  -version-info $(LIBAVAHI_CORE_VERSION_INFO)
 
 prioq_test_SOURCES = \
        prioq-test.c  \
@@ -140,7 +141,8 @@ dns_test_SOURCES = \
        util.c util.h \
        rr.c rr.h \
        hashmap.c hashmap.h \
-       domain-util.c domain-util.h
+       domain-util.c domain-util.h \
+       addr-util.c addr-util.h
 dns_test_CFLAGS = $(AM_CFLAGS)
 dns_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la