]> git.meshlink.io Git - catta/blobdiff - avahi-core/Makefile.am
forgot to pull the publish_no_reverse change to the example.
[catta] / avahi-core / Makefile.am
index 1a78368c2c5beecd1ed99bdf8761ec6d8cdf0b7f..2f095967718e8ffa26655157a39b0dec52525ed6 100644 (file)
@@ -1,7 +1,5 @@
-# $Id$
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
@@ -32,23 +30,31 @@ avahiinclude_HEADERS = \
        lookup.h
 
 lib_LTLIBRARIES = \
-       libavahi-core.la 
+       libavahi-core.la
 
+if ENABLE_TESTS
 noinst_PROGRAMS = \
        prioq-test \
        avahi-test \
        conformance-test \
        avahi-reflector \
        dns-test \
+       dns-spin-test \
        timeeventq-test \
        hashmap-test \
        querier-test \
        update-test
 
+TESTS = \
+       dns-spin-test \
+       dns-test \
+       hashmap-test
+endif
+
 libavahi_core_la_SOURCES = \
        timeeventq.c timeeventq.h\
        iface.c iface.h \
-       server.c server.h entry.c \
+       server.c internal.h entry.c \
        prioq.c prioq.h \
        cache.c cache.h \
        socket.c socket.h \
@@ -65,7 +71,7 @@ libavahi_core_la_SOURCES = \
        browse-service.c \
        resolve-service.c \
        dns.c dns.h \
-       rr.c rr.h \
+       rr.c rr.h rr-util.h \
        core.h lookup.h publish.h \
        log.c log.h \
        browse-dns-server.c \
@@ -74,17 +80,28 @@ libavahi_core_la_SOURCES = \
        hashmap.c hashmap.h \
        wide-area.c wide-area.h \
        multicast-lookup.c multicast-lookup.h \
-       querier.c querier.h
+       querier.c querier.h \
+       addr-util.h addr-util.c \
+       domain-util.h domain-util.c \
+       dns-srv-rr.h
 
 if HAVE_NETLINK
 libavahi_core_la_SOURCES += \
        iface-linux.c iface-linux.h \
        netlink.c netlink.h
+else
+if HAVE_PF_ROUTE
+libavahi_core_la_SOURCES += \
+       iface-pfroute.c iface-pfroute.h
+else
+libavahi_core_la_SOURCES += \
+       iface-none.c
+endif
 endif
 
 libavahi_core_la_CFLAGS = $(AM_CFLAGS)
 libavahi_core_la_LIBADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
-libavahi_core_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_CORE_VERSION_INFO)
+libavahi_core_la_LDFLAGS = $(AM_LDFLAGS)  -version-info $(LIBAVAHI_CORE_VERSION_INFO)
 
 prioq_test_SOURCES = \
        prioq-test.c  \
@@ -123,10 +140,17 @@ dns_test_SOURCES = \
        log.c log.h \
        util.c util.h \
        rr.c rr.h \
-       hashmap.c hashmap.h
+       hashmap.c hashmap.h \
+       domain-util.c domain-util.h \
+       addr-util.c addr-util.h
 dns_test_CFLAGS = $(AM_CFLAGS)
 dns_test_LDADD = $(AM_LDADD) ../avahi-common/libavahi-common.la
 
+dns_spin_test_SOURCES = \
+       dns-spin-test.c
+dns_spin_test_CFLAGS = $(AM_CFLAGS)
+dns_spin_test_LDADD = $(AM_LDADD) libavahi-core.la
+
 timeeventq_test_SOURCES = \
        timeeventq-test.c \
        timeeventq.h timeeventq.c \