]> git.meshlink.io Git - catta/blobdiff - avahi-compat-libdns_sd/Makefile.am
* Compile tests only when --enable-tests was specified on the configure command line
[catta] / avahi-compat-libdns_sd / Makefile.am
index 2b650595e5ecc986d17beca70eda96304d405c59..bd33bb0e6136c83bf6c4c3b87e6511149adc0dd2 100644 (file)
@@ -23,6 +23,7 @@ AM_CFLAGS=-I$(top_srcdir)
 AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
 
 if HAVE_DBUS
+if ENABLE_COMPAT_LIBDNS_SD
 
 avahi_compat_libdns_sddir=$(includedir)/avahi-compat-libdns_sd
 
@@ -30,7 +31,9 @@ avahi_compat_libdns_sd_HEADERS = dns_sd.h
 
 lib_LTLIBRARIES = libavahi-compat-libdns_sd.la 
 
+if ENABLE_TESTS
 noinst_PROGRAMS = txt-test
+endif
 
 libavahi_compat_libdns_sd_la_SOURCES = \
        dns_sd.h \
@@ -61,3 +64,4 @@ libdns_sd-test: libdns_sd-test.c libavahi-compat-libdns_sd.la
 CLEANFILES = libdns_sd-test.o libdns_sd-test
 
 endif
+endif