]> git.meshlink.io Git - catta/blobdiff - avahi-common/Makefile.am
forgot to pull the publish_no_reverse change to the example.
[catta] / avahi-common / Makefile.am
index f9fdef4b76b4fa9e5a77e0f5d88d92d8b7ba20f4..c78e34a7b7ea8f2a6100463f264f91e42d739422 100644 (file)
@@ -1,7 +1,5 @@
-# $Id: Makefile.am 90 2005-05-23 16:15:12Z lennart $
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
@@ -35,6 +33,7 @@ avahi_commoninclude_HEADERS = \
        watch.h \
        timeval.h \
        simple-watch.h \
+       thread-watch.h \
        gccmacro.h \
        error.h \
        llist.h \
@@ -46,11 +45,13 @@ noinst_PROGRAMS = \
        domain-test \
        alternative-test \
        timeval-test \
-       watch-test
+       watch-test \
+       watch-test-thread \
+       utf8-test
 endif
 
 lib_LTLIBRARIES = \
-       libavahi-common.la 
+       libavahi-common.la
 
 libavahi_common_la_SOURCES = \
        malloc.c malloc.h \
@@ -61,11 +62,15 @@ libavahi_common_la_SOURCES = \
        domain.c domain.h \
        timeval.c timeval.h \
        simple-watch.c simple-watch.h \
+       thread-watch.c thread-watch.h \
        watch.h gccmacro.h \
-       rlist.h rlist.c
+       rlist.h rlist.c \
+       utf8.c utf8.h \
+       i18n.c i18n.h
 
-libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) 
-libavahi_common_la_LDFLAGS = $(AM_LDFLAGS) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) -export-dynamic -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
+libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -DAVAHI_LOCALEDIR=\"$(avahilocaledir)\"
+libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) $(INTLLIBS)
+libavahi_common_la_LDFLAGS = $(AM_LDFLAGS)  -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
 
 strlst_test_SOURCES = \
        strlst.c strlst.h \
@@ -77,13 +82,17 @@ alternative_test_SOURCES = \
        alternative.c alternative.h \
        malloc.c malloc.h \
        domain.c domain.h \
-       alternative-test.c
+       address.c address.h \
+       alternative-test.c \
+       utf8.c utf8.h
 alternative_test_CFLAGS = $(AM_CFLAGS)
 
 domain_test_SOURCES = \
        domain.c domain.h \
        malloc.c malloc.h \
-       domain-test.c
+       address.c address.h \
+       domain-test.c \
+       utf8.c utf8.h
 domain_test_CFLAGS = $(AM_CFLAGS)
 
 watch_test_SOURCES = \
@@ -95,17 +104,18 @@ watch_test_SOURCES = \
 watch_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
 watch_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS)
 
+watch_test_thread_SOURCES = $(watch_test_SOURCES) thread-watch.c thread-watch.h
+watch_test_thread_CFLAGS = $(watch_test_CFLAGS) -DUSE_THREAD
+watch_test_thread_LDADD = $(watch_test_LDADD)
+
 timeval_test_SOURCES = \
        timeval.c timeval.h \
        timeval-test.c
 timeval_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
 timeval_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS)
 
-if HAVE_DBUS
-
-noinst_HEADERS = \
-       dbus.h \
-       dbus-watch-glue.h
-
-endif
-
+utf8_test_SOURCES = \
+       utf8-test.c \
+       utf8.c utf8.h
+utf8_test_CFLAGS = $(AM_CFLAGS)
+utf8_test_LDADD = $(AM_LDADD)