]> git.meshlink.io Git - catta/blobdiff - avahi-common/Makefile.am
forgot to pull the publish_no_reverse change to the example.
[catta] / avahi-common / Makefile.am
index cd21c11d78b8db83ea8cfe4d42090338f5b3b1de..c78e34a7b7ea8f2a6100463f264f91e42d739422 100644 (file)
@@ -1,7 +1,5 @@
-# $Id: Makefile.am 90 2005-05-23 16:15:12Z lennart $
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
@@ -53,7 +51,7 @@ noinst_PROGRAMS = \
 endif
 
 lib_LTLIBRARIES = \
-       libavahi-common.la 
+       libavahi-common.la
 
 libavahi_common_la_SOURCES = \
        malloc.c malloc.h \
@@ -67,11 +65,12 @@ libavahi_common_la_SOURCES = \
        thread-watch.c thread-watch.h \
        watch.h gccmacro.h \
        rlist.h rlist.c \
-       utf8.c utf8.h
+       utf8.c utf8.h \
+       i18n.c i18n.h
 
-libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) 
-libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS)
-libavahi_common_la_LDFLAGS = $(AM_LDFLAGS) -export-dynamic -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
+libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -DAVAHI_LOCALEDIR=\"$(avahilocaledir)\"
+libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) $(INTLLIBS)
+libavahi_common_la_LDFLAGS = $(AM_LDFLAGS)  -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
 
 strlst_test_SOURCES = \
        strlst.c strlst.h \
@@ -120,12 +119,3 @@ utf8_test_SOURCES = \
        utf8.c utf8.h
 utf8_test_CFLAGS = $(AM_CFLAGS)
 utf8_test_LDADD = $(AM_LDADD)
-
-if HAVE_DBUS
-
-noinst_HEADERS = \
-       dbus.h \
-       dbus-watch-glue.h
-
-endif
-