]> git.meshlink.io Git - catta/blobdiff - avahi-common/Makefile.am
forgot to pull the publish_no_reverse change to the example.
[catta] / avahi-common / Makefile.am
index b96d19e44cf18a2ce367784b3e315f2248a47427..c78e34a7b7ea8f2a6100463f264f91e42d739422 100644 (file)
@@ -1,7 +1,5 @@
-# $Id: Makefile.am 90 2005-05-23 16:15:12Z lennart $
-#
 # This file is part of avahi.
-# 
+#
 # avahi is free software; you can redistribute it and/or modify it
 # under the terms of the GNU Lesser General Public License as
 # published by the Free Software Foundation; either version 2 of the
 
 AM_CFLAGS=-I$(top_srcdir)
 
-# GLIB 2.0
-AM_CFLAGS+=$(GLIB20_CFLAGS)
-AM_LDADD=$(GLIB20_LIBS)
-
 # This cool debug trap works on i386/gcc only
 AM_CFLAGS+='-DDEBUG_TRAP=__asm__("int $$3")'
 
@@ -32,55 +26,96 @@ avahi_commoninclude_HEADERS = \
        strlst.h \
        address.h \
        alternative.h \
-       rr.h \
-       util.h \
-       cdecl.h
-
-if ENABLE_DBUS
-avahi_commoninclude_HEADERS += dbus.h
-endif
-
-noinst_HEADERS = llist.h
+       domain.h \
+       cdecl.h \
+       defs.h \
+       malloc.h \
+       watch.h \
+       timeval.h \
+       simple-watch.h \
+       thread-watch.h \
+       gccmacro.h \
+       error.h \
+       llist.h \
+       rlist.h
 
+if ENABLE_TESTS
 noinst_PROGRAMS = \
        strlst-test \
        domain-test \
        alternative-test \
-       timeval-test
+       timeval-test \
+       watch-test \
+       watch-test-thread \
+       utf8-test
+endif
 
 lib_LTLIBRARIES = \
-       libavahi-common.la 
+       libavahi-common.la
 
 libavahi_common_la_SOURCES = \
+       malloc.c malloc.h \
        address.c address.h \
-       strlst.c strlst.h \
        alternative.c alternative.h \
-       rr.c rr.h \
-       util.c util.h
-libavahi_common_la_CFLAGS = $(AM_CFLAGS)
-libavahi_common_la_LIBADD = $(AM_LDADD)
+       error.c error.h \
+       strlst.c strlst.h \
+       domain.c domain.h \
+       timeval.c timeval.h \
+       simple-watch.c simple-watch.h \
+       thread-watch.c thread-watch.h \
+       watch.h gccmacro.h \
+       rlist.h rlist.c \
+       utf8.c utf8.h \
+       i18n.c i18n.h
+
+libavahi_common_la_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS) -DAVAHI_LOCALEDIR=\"$(avahilocaledir)\"
+libavahi_common_la_LIBADD = $(AM_LDADD) $(PTHREAD_CFLAGS) $(PTHREAD_LIBS) $(INTLLIBS)
+libavahi_common_la_LDFLAGS = $(AM_LDFLAGS)  -version-info $(LIBAVAHI_COMMON_VERSION_INFO)
 
 strlst_test_SOURCES = \
        strlst.c strlst.h \
+       malloc.c malloc.h \
        strlst-test.c
 strlst_test_CFLAGS = $(AM_CFLAGS)
-strlst_test_LDADD = $(AM_LDADD)
 
 alternative_test_SOURCES = \
        alternative.c alternative.h \
-       alternative-test.c
+       malloc.c malloc.h \
+       domain.c domain.h \
+       address.c address.h \
+       alternative-test.c \
+       utf8.c utf8.h
 alternative_test_CFLAGS = $(AM_CFLAGS)
-alternative_test_LDADD = $(AM_LDADD)
 
 domain_test_SOURCES = \
-       util.c util.h \
-       domain-test.c
+       domain.c domain.h \
+       malloc.c malloc.h \
+       address.c address.h \
+       domain-test.c \
+       utf8.c utf8.h
 domain_test_CFLAGS = $(AM_CFLAGS)
-domain_test_LDADD = $(AM_LDADD)
+
+watch_test_SOURCES = \
+       timeval.c timeval.h \
+       simple-watch.c simple-watch.h \
+       watch.h \
+       malloc.c malloc.h \
+       watch-test.c
+watch_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
+watch_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS)
+
+watch_test_thread_SOURCES = $(watch_test_SOURCES) thread-watch.c thread-watch.h
+watch_test_thread_CFLAGS = $(watch_test_CFLAGS) -DUSE_THREAD
+watch_test_thread_LDADD = $(watch_test_LDADD)
 
 timeval_test_SOURCES = \
-       util.c util.h \
+       timeval.c timeval.h \
        timeval-test.c
-timeval_test_CFLAGS = $(AM_CFLAGS)
-timeval_test_LDADD = $(AM_LDADD)
+timeval_test_CFLAGS = $(AM_CFLAGS) $(PTHREAD_CFLAGS)
+timeval_test_LDADD = $(AM_LDADD) $(PTHREAD_LIBS) $(PTHREAD_CFLAGS)
 
+utf8_test_SOURCES = \
+       utf8-test.c \
+       utf8.c utf8.h
+utf8_test_CFLAGS = $(AM_CFLAGS)
+utf8_test_LDADD = $(AM_LDADD)