]> git.meshlink.io Git - catta/blobdiff - initscript/gentoo/Makefile.am
fix avahi_netlink_new to allow multiple netlinks per process
[catta] / initscript / gentoo / Makefile.am
index 4165ad3ef49a6594a93e899ef0da275b41ce3110..0d20ca6f79fbd41f090524ffed828f46c19dbb51 100644 (file)
@@ -1,5 +1,3 @@
-# $Id$
-
 # This file is part of avahi.
 #
 # avahi is free software; you can redistribute it and/or modify it
 # Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
 # USA.
 
+if !HAVE_DBUS
+NO_DBUS_DEPENDENCY=/need dbus/d
+endif
+
 initddir = $(sysconfdir)/init.d
 
 EXTRA_DIST = \
@@ -32,7 +34,8 @@ CLEANFILES = \
        avahi-dnsconfd
 
 avahi-daemon: avahi-daemon.in
-       sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+
+       sed -e 's,@sbindir\@,$(sbindir),g; $(NO_DBUS_DEPENDENCY)' $< > $@
        chmod +x $@
 
 avahi-dnsconfd: avahi-dnsconfd.in