]> git.meshlink.io Git - catta/blobdiff - initscript/gentoo/Makefile.am
* New gentoo init scripts from Sven Wegener
[catta] / initscript / gentoo / Makefile.am
index 6e69bb28592cd8dd209efcb41d7bf14af4d4ae1e..4165ad3ef49a6594a93e899ef0da275b41ce3110 100644 (file)
@@ -1,4 +1,40 @@
-dbusinitddir = $(sysconfdir)/init.d
-dbusinitd_SCRIPTS = avahi-daemon avahi-dnsconfd
+# $Id$
 
-EXTRA_DIST = $(dbusinitd_SCRIPTS)
+# This file is part of avahi.
+#
+# avahi is free software; you can redistribute it and/or modify it
+# under the terms of the GNU Lesser General Public License as
+# published by the Free Software Foundation; either version 2 of the
+# License, or (at your option) any later version.
+#
+# avahi is distributed in the hope that it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY
+# or FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public
+# License for more details.
+#
+# You should have received a copy of the GNU Lesser General Public
+# License along with avahi; if not, write to the Free Software
+# Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307
+# USA.
+
+initddir = $(sysconfdir)/init.d
+
+EXTRA_DIST = \
+       avahi-daemon.in \
+       avahi-dnsconfd.in
+
+initd_SCRIPTS = \
+       avahi-daemon \
+       avahi-dnsconfd
+
+CLEANFILES = \
+       avahi-daemon \
+       avahi-dnsconfd
+
+avahi-daemon: avahi-daemon.in
+       sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+       chmod +x $@
+
+avahi-dnsconfd: avahi-dnsconfd.in
+       sed -e 's,@sbindir\@,$(sbindir),g' $< > $@
+       chmod +x $@